Audio bei Export mit Video nicht synchron

Moderatoren: d/flt prod., MarkDVC, Mods

Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 8:20

F: Video nicht synchron

Hallo zusammen Ich bin Musiker und erstelle Drum-Tutorials (Videos) in LogicProX 10.3.1 und iMovie 10.1.6. Dazu lasse ich einen Song in Logic laufen, spiele dazu
Hallo zusammen

Ich bin Musiker und erstelle Drum-Tutorials (Videos) in LogicProX 10.3.1 und iMovie 10.1.6. Dazu lasse ich einen Song in Logic laufen, spiele dazu Drums und nehme das mit meinem iPhone7 auf (mit 60fps). Danach möchte ich in iMovie jedoch nicht den aufgenommenen Videoton verwenden, sondern den Originaltrack in Logic, welchen ich dort via Bouncen exportiere.

Das Problem ist; wenn ich das Video und den Logic-Audio-Track in iMovie zusammenführe, sind diese nicht synchron! Ich habe vor dem Bouncen des Tracks schon verschiedene Formate und Bitraten ausprobiert. Auch das ändern der I/O Puffergrössen hat nichts gebracht und auch nicht das durchprobieren von verschiedenen Frame-Raten. Die Audiodatei bleibt immer etwas kürzer als die des Videos.

Kann mir da jemand weiterhelfen? Was mache ich falsch?
Herzlichen Dank
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Stephan S » 19 Jun 2017 - 9:09

Du musst den Ton in Logic mit 48 khz Samplingrate verarbeiten bzw. so konvertiert ausgeben.

"Quotes found on the internet are not always accurate" - Abraham Lincoln
Produktionen, Mix und (Fern-)Unterricht:
http://www.sounddesign-pro.com
Benutzeravatar
Stephan S
Super Tweaker
 
Beiträge: 11116
Registriert: 20 Okt 2005 - 15:43
Wohnort: Berlin

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 13:54

Danke vielmals für deine Antwort Stephan. Ich habe nun bei den Projekteinstellungen von Logic die Abtastrate auf 48kHz eingestellt und beim Bouncen AAC 48 kBit/s eingestellt. Dies hat jedoch nicht den gewünschten Erfolg gebracht, der Audiotrack ist nach dem Import in iMovie immer noch etwas zu schnell im Vergleich zum aufgenommenen Video.(nach 3'30'' ca. 200 Millisekunden).
Oder muss ich das Video auch noch einmal aufnehmen mit den neuen Einstellungen in Logic?
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Wizz » 19 Jun 2017 - 14:06

exportiere aus logic nicht als AAC sondern Wav/ 48khz. kBit/s ist was anderes.
Wizz
Haudegen
 
Beiträge: 504
Registriert: 30 Sep 2010 - 8:56

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 14:16

Wave Export hat leider auch nichts gebracht, das Tempo des Tracks bleibt sich immer genau gleich. Auch verschiedene Wave-Bit Versionen habe ich ausprobiert - bringt ebenfalls nichts....
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Wizz » 19 Jun 2017 - 14:25

damit wirst du leben müssen. oder du benutzt ne cam wo man die fps einstellen kannst und nimmst gleich mit 24fps auf oder ne video software wo du es ausgleichen kannst. den das iphone nimmt 60frames dropframe auf und was imovie daraus macht weiß auch keiner.

meine wahrsager kugel sagt: es liegt eher am video/setup als am audio.
Wizz
Haudegen
 
Beiträge: 504
Registriert: 30 Sep 2010 - 8:56

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 14:32

Danke Wizz, das glaube ich langsam auch, dass der Fehler beim Video liegt, da alle Exporteinstellungen immer zum gleichen Ergebnis geführt haben.
Ich könnte beim iPhone ja auch auf 30 fps umstellen. Sagt dann deine Wahrsager-Kugel, dass dann der Zeitunterschied kleiner wird?
Weisst du per Zufall ob man mit Final Cut pro x diese Frames ausgleichen könnte?
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Wizz » 19 Jun 2017 - 14:47

ich vermute das dass iPhone ne art variabler framerate arbeitet, sprich mit 30 frames dauert es ein wenig länger aber es läuft auch auseinander. du hast das pech dass du drummer bist , anderen leuten würden die 200ms garnicht auffallen :lol:

jetzt nur als wordaround: ich denk mal du hast nur eine cam benutzt? nimm doch einfach einpaar details (Bassdrum, Snare ) richtig nah auf.
zieh dein original video in logic und ediere es, also wenn du merkst das es auseinander läuft mach ein schnitt und schieb es ran. später in imovie benutzt du deine closeups zum kaschieren.

macht das sinn?
Wizz
Haudegen
 
Beiträge: 504
Registriert: 30 Sep 2010 - 8:56

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 15:18

Ja das macht schon Sinn, aber dann habe ich wieder viele Arbeitsschritte mehr. Ich erstelle ziemlich viele Videos, welche ich dann möglichst ohne viel Arbeitsaufwand zusammensetzen möchte. Bisher habe ich einfach die Audiospur in iMovie durch pröbeln verlangsamt bis es gepasst hat. Es wäre aber toll wenn ich meinem Arbeitsablauf so einfach wie möglich halten könnte. Ich habe gedacht, dass das eigentlich möglich sein sollte eine Aufnahme und einen Bounce synchron zu halten! :roll:
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Wizz » 19 Jun 2017 - 15:44

du hast zwei Baustellen, die cam die wahrscheinlich intern schon ein ungenaueres video ablegt.
und audio. könnte auch sein das clock vom interface da ungenau arbeitet. (welches interface benutzt du eigentlich?)

wie gesagt das ist kein software fehler, eher hardware die bei der aufnahme probleme macht. wenn du einen schnellen workflow brauchst, musst wohl oder übel eins der beiden möglichen Fehlerquellen ersetzten vielleicht sogar beide.
Wizz
Haudegen
 
Beiträge: 504
Registriert: 30 Sep 2010 - 8:56

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 16:00

als Interface benutze ich ein Focusrite Clarett 2pre.
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Clemens Vill » 19 Jun 2017 - 16:05

Musst Du in iMovie schneiden?

Wenn nicht, kannst Du die komplette Nachvertonung direkt in Logic machen.

Logic-Projekt mit dem Soundtrack öffnen.
Ablage -> Film -> Film öffnen - Audiotrack extrahieren
Die Audioregion des Film stummschalten oder Volume reduzieren
Arrangement passend zurechtrücken
Ablage->Film->Audio in Film exportieren

Beim Exportieren kommt (bei mir) ein Fenster mit Spurauswahl usw. - da sind die Arrangement-Spuren gar nicht aufgeführt.
Ich lasse da alles wie's ist und klicke nur "weiter" und der Film hat den neuen Ton.
Sei Du selbst. Andere gibt es schon genug.
Benutzeravatar
Clemens Vill
Moderator
 
Beiträge: 4939
Registriert: 22 Mai 2009 - 7:25

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 16:33

Das ist eine gute Frage, wo ich mal genauer auschecken muss. In iMovie importieren muss ich aber sowieso, da ich ja dort Titel, Überblendungen und so erstelle...
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Re: Audio bei Export mit Video nicht synchron

Beitragvon Axel » 19 Jun 2017 - 21:09

Ich würde denken, da gehts um die richtige Framerate. 200 ms bei 3'30 könnte auf ein Dropframe-Format Kameraseitig hinweisen. Kann iMovie etwas zum Format des importierten Videos aussagen? Sonst mal das Footage im QT-Player öffnen und auf cmd-i drücken.
Producer | Writer | war nicht bei 3 aufm Baum | axel[äd]germanwahnsinn.de
Benutzeravatar
Axel
Stamm User
 
Beiträge: 3280
Registriert: 25 Nov 2002 - 18:11
Wohnort: Hamburch

Re: Audio bei Export mit Video nicht synchron

Beitragvon Kuri » 19 Jun 2017 - 21:16

Hallo Axel

Danke für deinen Input. Bei den QT-Player Infos steht:
Format: H.264, 1920 x 1080
AAC, 44100 Hz, Mono
FPS: 59.96
Datengrösse: 834.6 MB
Datenrate: 23.47 MBit/s
Aktuelle Grösse: 1680 x 945
Kuri
Jungspund
 
Beiträge: 14
Registriert: 19 Jun 2017 - 8:13

Nächste

Zurück zu Logic X